yum update 执行报错: error : unpacking of archive failed on file /usr/.../...;5d26ff7c: cpio : symlink

时间:2019-07-23 21:41:00 来源:互联网 作者: 神秘的大神 字体:

早前已发现有台机一直在报这么个错误, 一用yum update 就报一堆:

 

Error: unpacking rpm package .....

error: xxxx : install failed

error : unpacking of archive failed on file /usr/.../...;5d26ff7c: cpio : symlink    (注意黑体,这个可能是报错编号,如果相同可以参考我的方法,如果不同建议再尝试)

 

Error: unpacking rpm package .....

error: xxxx : install failed

error : unpacking of archive failed on file /usr/.../...;5d26ff7c: cpio : open

 

尝试使用rpm进行升级,结果rpm也报一样的错误,什么都做不了。。。。

 

研究cpio 发现什么都研究不出来,

想想哥多年的运维经验:一般这类型报错,报的跟错的隔着十万八千里的联系,也就懒得去深究这cpio是什么了

 

再看yum update 信息, 居然意外发现了猫腻:

发现有这么一行信息

 

32:bind-utils-9.9.4-61.el7.x86_64 was supposed to bo removed but is not! (一般上面报错下面各种失败是正常的再看下面)

  verifying  :   32:bind-utils-9.9.4-61.el7.x86_64      (我擦。。这又是rpm -ivh惹的祸)

  verifying  :   32:bind-utils-9.9.4-74.el7_6.1.x86_64

  verifying  :   32:bind-libs-lite-9.9.4-74.el7_6.1.x86_64

 

一般情况下,有这类型报错也就是失败结果而已,没什么帮助。 但是出现同一个包有两个版本就另一回事了,呐实际上又是这么一个奇葩搞出来的报错。

 

yum remove 32:bind-utils-9.9.4-61.el7.x86_64   -y  

...

成功了!

 

接下来各种update。。。

都成功了!

 

结论:有空再分析吧