怎样选择PHP的版本

时间:2016-06-23 14:36:55 来源:互联网 作者: 神秘的大神 字体:

IIS

如果想使用IIS配置PHP的话,那么需要选择Non-Thread Safe(NTS)版本的PHP

Apache

如果你是用的Apache的版本来自Apache Lounge(website:http://apachelounge.com/),可以使用PHP VC11 x86或者x64版本。

如果你使用的是从apache.org下载的Apache1或者Apache2来搭建PHP环境的话,只能使用VC6版本,无法使用VC9+以上版本。

VC9 和VC11

VC9和VC11是PHP的最新版本(这两个版本分别通过Visual Studio 2008和Visual Studio 2012编译),其中包含了对于性能和稳定性的改进。

VC9版本要求用户安装Microsoft Visual C++ 2008 SP1 Redistributable Package(x86 | x64)

VC11版本要求用户安装Visual C++ Redistributable for Visual Studio 2012(x86 | x64)